(RHSA-2005:878) cups security update

2005-12-20T05:00:00
ID RHSA-2005:878
Type redhat
Reporter RedHat
Modified 2017-09-08T12:08:18

Description

The Common UNIX Printing System (CUPS) provides a portable printing layer for UNIX(R) operating systems.

Several flaws were discovered in the way CUPS processes PDF files. An attacker could construct a carefully crafted PDF file that could cause CUPS to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3191, CVE-2005-3192, and CVE-2005-3193 to these issues.

All users of CUPS should upgrade to these updated packages, which contain backported patches to resolve these issues.