(RHSA-2002:211) ggv security update

2003-02-06T05:00:00
ID RHSA-2002:211
Type redhat
Reporter RedHat
Modified 2018-03-14T19:26:26

Description

Gv and ggv are user interfaces for the Ghostscript PostScript(R) interpreter used to display PostScript and PDF documents on an X Window System. KGhostview is the PostScript viewer for the K Desktop Environment.

Zen Parse found a local buffer overflow in gv version 3.5.8 and earlier. An attacker can create a carefully crafted malformed PDF or PostScript file in such a way that when that file is viewed arbitrary commands can be executed.

ggv and kghostview contain code derived from gv and therefore have the same vulnerability.

All users of gv, ggv, and kghostview are advised to upgrade to the errata packages which contain patches to correct the vulnerability.