PT-2014-78: Cross-site scripting in Kasseler CMS

2014-12-29T00:00:00
ID PT-2014-78
Type ptsecurity
Reporter Positive Technologies
Modified 1970-01-01T00:00:00

Description

PT-2014-78: Cross-site scripting in Kasseler CMS

Vulnerable software

Kasseler CMS

Version: r1190 and earlier

Link:
<http://www.kasseler-cms.net/>

Severity level

Severity level: Medium
Impact: Cross-site scripting
Access Vector: Remote

CVSS v2:
Base Score: 4.3
Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVE: not assigned

Software description

Kasseler CMS is a web content management system.

Vulnerability description

The specialists of the Positive Research center have detected a Cross-site scripting vulnerability in Kasseler CMS.

Insufficient validation of user input in the \function\init.php script allows remote attackers to include files located on the attacked server and thus execute a PHP code. It may result in sensitive data disclosure, obtaining of application source code, configuration files, server compromising, etc.

How to fix

Update your software up to the latest version.

Advisory status

11.12.2013 - Vendor gets vulnerability details
25.12.2013 - Vendor releases fixed version and details
29.12.2014 - Public disclosure

Credits

The vulnerability was detected by using Positive Technologies Application Inspector, the application security testing system

References

<http://en.securitylab.ru/lab/PT-2014-78>

Reports on the vulnerabilities previously discovered by Positive Research:

<http://www.ptsecurity.com/research/advisory/>
<http://en.securitylab.ru/lab/>