DOS vulnerabiltiy in table editing
It was possible to trigger recursive include operation by crafter parameters when editing table data.
We consider this to be non critical.
Do not click on deep phpMyAdmin links on third party sites.
All 4.6.x versions (prior to 4.6.6), 4.4.x versions (prior to 220.127.116.11), and 4.0.x versions (prior to 18.104.22.168) are affected.
Upgrade to phpMyAdmin 4.6.6, 22.214.171.124, or 126.96.36.199 or newer or apply patch listed below.
Thanks to Emanuel Bronshtein @e3amn2l for reporting this vulnerability.
Assigned CVE ids: CVE-2017-1000014
CWE ids: CWE-661
The following commits have been made on the 4.0 branch to fix this issue:
The following commits have been made on the 4.4 branch to fix this issue:
The following commits have been made on the 4.6 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.