Bypass logout timeout

2016-11-25T00:00:00
ID PHPMYADMIN:PMASA-2016-62
Type phpmyadmin
Reporter phpMyAdmin
Modified 2016-12-06T00:00:00

Description

PMASA-2016-62

Announcement-ID: PMASA-2016-62

Date: 2016-11-25

Updated: 2016-12-06

Summary

Bypass logout timeout

Description

With a crafted request parameter value it is possible to bypass the logout timeout.

Severity

We consider this vulnerability to be of moderate severity.

Affected Versions

All 4.6.x versions (prior to 4.6.5), and 4.4.x versions (prior to 4.4.15.9) are affected.

Solution

Upgrade to phpMyAdmin 4.6.5, 4.4.15.9 or newer or apply patch listed below.

References

Thanks to Emanuel Bronshtein @e3amn2l for reporting this vulnerability.

Assigned CVE ids: CVE-2016-9851

CWE ids: CWE-661

Patches

The following commits have been made on the 4.4 branch to fix this issue:

The following commits have been made on the 4.6 branch to fix this issue:

More information

For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.