XSS through FPD

2016-06-23T00:00:00
ID PHPMYADMIN:PMASA-2016-24
Type phpmyadmin
Reporter phpMyAdmin
Modified 2016-06-23T00:00:00

Description

PMASA-2016-24

Announcement-ID: PMASA-2016-24

Date: 2016-06-23

Summary

XSS through FPD

Description

With a specially crafted request, it is possible to trigger an XSS attack through the example OpenID authentication script.

Severity

We do not consider this vulnerability to be secure due to the non-standard required PHP setting for html_errors.

Mitigation factor

The attack requires html_errors = Off in php.ini, so it can be mitigated by setting html_errors = On. As an alternative mitigation means, the ./examples/openid.php file can be removed.

Affected Versions

All 4.6.x versions (prior to 4.6.3), 4.4.x versions (prior to 4.4.15.7), and 4.0.x versions (prior to 4.0.10.16) are affected

Solution

Upgrade to phpMyAdmin 4.6.3, 4.4.15.7, or 4.0.10.16 or newer or apply patch listed below.

References

Thanks to Emanuel Bronshtein @e3amn2l for reporting this vulnerability.

Assigned CVE ids: CVE-2016-5731

CWE ids: CWE-661

Patches

The following commits have been made on the 4.0 branch to fix this issue:

The following commits have been made on the 4.4 branch to fix this issue:

The following commits have been made on the 4.6 branch to fix this issue:

More information

For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.