Vulnerability allowing man-in-the-middle attack on API call to GitHub.

2015-05-13T00:00:00
ID PHPMYADMIN:PMASA-2015-3
Type phpmyadmin
Reporter phpMyAdmin
Modified 2015-05-13T00:00:00

Description

PMASA-2015-3

Announcement-ID: PMASA-2015-3

Date: 2015-05-13

Summary

Vulnerability allowing man-in-the-middle attack on API call to GitHub.

Description

A vulnerability in the API call to GitHub can be exploited to perform a man-in-the-middle attack.

Severity

We consider this vulnerability to be serious.

Affected Versions

Versions 4.0.x (prior to 4.0.10.10), 4.2.x (prior to 4.2.13.3), 4.3.x (prior to 4.3.13.1) and 4.4.x (prior to 4.4.6.1) are affected.

Solution

Upgrade to phpMyAdmin 4.0.10.10 or newer, or 4.2.13.3 or newer, or 4.3.13.1 or newer, or 4.4.6.1 or newer, or apply the patch listed below.

References

Thanks to Maksymilian Arciemowicz of <http://cxsecurity.com> for reporting this vulnerability.

Assigned CVE ids: CVE-2015-3903

CWE ids: CWE-661 CWE-295

Patches

The following commits have been made to fix this issue:

The following commits have been made on the 4.0 branch to fix this issue:

The following commits have been made on the 4.2 branch to fix this issue:

The following commits have been made on the 4.3 branch to fix this issue:

More information

For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.