Z-Vote 1.1 SQL Injection

Type packetstorm
Reporter High-Tech Bridge SA
Modified 2011-02-22T00:00:00


                                            `Vulnerability ID: HTB22839  
Reference: http://www.htbridge.ch/advisory/sql_injection_in_z_vote_wordpress_plugin.html  
Product: Z-Vote wordpress plugin  
Vendor: 140hours ( http://wordpress.org/extend/plugins/z-vote/ )   
Vulnerable Version: 1.1  
Vendor Notification: 08 February 2011   
Vulnerability Type: SQL Injection  
Risk level: High   
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)   
Vulnerability Details:  
The vulnerability exists due to failure in the "/zvote.php" script to properly sanitize user-supplied input in "zvote" variable.  
Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.  
The following PoC is available: