e107 0.7.23 SQL Injection

2010-09-21T00:00:00
ID PACKETSTORM:94055
Type packetstorm
Reporter High-Tech Bridge SA
Modified 2010-09-21T00:00:00

Description

                                        
                                            `===============================================  
Vulnerability ID: HTB22603  
Reference: http://www.htbridge.ch/advisory/sql_injection_vulnerability_in_e107_1.html  
Product: e107 Website System  
Vendor: e107 ( http://www.e107.org/ )   
Vulnerable Version: 0.7.23 and Probably Prior Versions  
Vendor Notification: 03 September 2010   
Vulnerability Type: SQL Injection  
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response  
Risk level: Low   
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)   
  
Vulnerability Details:  
The vulnerability exists due to failure in the "download.php" script to properly sanitize user-supplied input in GET parameter. Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.  
  
Attacker can use browser to exploit this vulnerability. The following PoC is available:  
  
  
http://host/e107_admin/download.php?cat.edit.999999%0Aunion%0Aselect%0A1,2,3,4,5,6,7  
  
  
===============================================  
Vulnerability ID: HTB22602  
Reference: http://www.htbridge.ch/advisory/sql_injection_vulnerability_in_e107.html  
Product: e107 Website System  
Vendor: e107 ( http://www.e107.org/ )   
Vulnerable Version: 0.7.23 and Probably Prior Versions  
Vendor Notification: 03 September 2010   
Vulnerability Type: SQL Injection  
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response  
Risk level: Low   
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)   
  
Vulnerability Details:  
The vulnerability exists due to failure in the wmessage.php script to properly sanitize user-supplied input in GET parameter. Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.  
  
Attacker can use browser to exploit this vulnerability. The following PoC is available:  
  
  
http://host/e107_admin/wmessage.php?create.edit.999999%0Aunion%0Aselect%0A1,2,user%28%29  
  
  
  
`