eazyCMS Cross Site Scripting

2010-08-13T00:00:00
ID PACKETSTORM:92772
Type packetstorm
Reporter High-Tech Bridge SA
Modified 2010-08-13T00:00:00

Description

                                        
                                            `===========================================  
Vulnerability ID: HTB22553  
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_eazycms.html  
Product: eazyCMS  
Vendor: eazycms.com ( http://eazycms.com/ )   
Vulnerable Version: Current at 28.07.2010 and Probably Prior Versions  
Vendor Notification: 28 July 2010   
Vulnerability Type: XSS (Cross Site Scripting)  
Status: Fixed by Vendor  
Risk level: Medium   
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)   
  
Vulnerability Details:  
User can execute arbitrary JavaScript code within the vulnerable application.  
  
The vulnerability exists due to failure in the "eazycms.php" script to properly sanitize user-supplied input in "page_id" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.  
  
An attacker can use browser to exploit this vulnerability. The following PoC is available:  
  
  
http://admin.host/eazycms.php?action=&page_id=2%22%3E%3Cscript%3Ealert%28document.cookie%29%3C/script%3E  
  
Solution: As this is an online service, there is no need to upgrade. Changes are live from time of publication.  
  
  
===========================================  
Vulnerability ID: HTB22554  
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_eazycms_1.html  
Product: eazyCMS  
Vendor: eazycms.com ( http://eazycms.com/ )   
Vulnerable Version: Current at 28.07.2010 and Probably Prior Versions  
Vendor Notification: 28 July 2010   
Vulnerability Type: XSS (Cross Site Scripting)  
Status: Fixed by Vendor  
Risk level: Medium   
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)   
  
Vulnerability Details:  
User can execute arbitrary JavaScript code within the vulnerable application.  
  
The vulnerability exists due to failure in the "formedit.php" script to properly sanitize user-supplied input in "filter_keywords" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.  
  
An attacker can use browser to exploit this vulnerability. The following PoC is available:  
  
  
http://admin.host/formedit.php?action=list&filter_keywords=%22%3E%3Cscript%3Ealert%28document.cookie%29%3C/script%3E  
  
Solution: As this is an online service, there is no need to upgrade. Changes are live from time of publication.  
  
  
  
===========================================  
Vulnerability ID: HTB22556  
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_eazycms_3.html  
Product: eazyCMS  
Vendor: eazycms.com ( http://eazycms.com/ )   
Vulnerable Version: Current at 28.07.2010 and Probably Prior Versions  
Vendor Notification: 28 July 2010   
Vulnerability Type: XSS (Cross Site Scripting)  
Status: Fixed by Vendor  
Risk level: Medium   
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)   
  
Vulnerability Details:  
User can execute arbitrary JavaScript code within the vulnerable application.  
  
The vulnerability exists due to failure in the "eazycms_header.php" script to properly sanitize user-supplied input in "title" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.  
  
An attacker can use browser to exploit this vulnerability. The following PoC is available:  
  
  
http://host/eazycms_header.php?title=%3Cscript%3Ealert%28document.cookie%29%3C/script%3E  
  
Solution: As this is an online service, there is no need to upgrade. Changes are live from time of publication.  
  
  
===========================================  
Vulnerability ID: HTB22557  
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_eazycms_4.html  
Product: eazyCMS  
Vendor: eazycms.com ( http://eazycms.com/ )   
Vulnerable Version: Current at 28.07.2010 and Probably Prior Versions  
Vendor Notification: 28 July 2010   
Vulnerability Type: XSS (Cross Site Scripting)  
Status: Fixed by Vendor  
Risk level: Medium   
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)   
  
Vulnerability Details:  
User can execute arbitrary JavaScript code within the vulnerable application.  
  
The vulnerability exists due to failure in the "indexcms.php" script to properly sanitize user-supplied input in "username" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.  
  
An attacker can use browser to exploit this vulnerability. The following PoC is available:  
  
  
http://admin.host/indexcms.php?error_code=-1&username=1%22%3E%3Cimg+src=x+onerror=alert%28document.cookie%29%3E  
  
Solution: As this is an online service, there is no need to upgrade. Changes are live from time of publication.  
`