MODx CMS 1.0.3 SQL Injection

2010-06-16T00:00:00
ID PACKETSTORM:90668
Type packetstorm
Reporter High-Tech Bridge SA
Modified 2010-06-16T00:00:00

Description

                                        
                                            `Vulnerability ID: HTB22414  
Reference: http://www.htbridge.ch/advisory/sql_injection_vulnerability_in_modx_cms.html  
Product: MODx CMS and Application Framework  
Vendor: MODx   
Vulnerable Version: 1.0.3 and Probably Prior Versions  
Vendor Notification: 28 May 2010   
Vulnerability Type: SQL Injection  
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response  
Risk level: Medium   
Credit: High-Tech Bridge SA (http://www.htbridge.ch/)   
  
Vulnerability Details:  
The vulnerability exists due to failure in the [xxx] script to properly sanitize user-supplied input in [yyy] variable. Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.  
  
Attacker can use browser to exploit this vulnerability. The following PoC is available:  
  
  
http://host/manager/index.php?id=4'+ANY_SQL&a=16  
  
You must also set the "Referer" HTTP header  
  
  
Vulnerability ID: HTB22413  
Reference: http://www.htbridge.ch/advisory/sql_injection_vulnerability_in_modx_cms_and_application_framework_1.html  
Product: MODx CMS and Application Framework  
Vendor: MODx   
Vulnerable Version: 1.0.3 and Probably Prior Versions  
Vendor Notification: 28 May 2010   
Vulnerability Type: SQL Injection  
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response  
Risk level: Medium   
Credit: High-Tech Bridge SA (http://www.htbridge.ch/)   
  
Vulnerability Details:  
The vulnerability exists due to failure in the [xxx] script to properly sanitize user-supplied input in [yyy] variable. Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.  
  
Attacker can use browser to exploit this vulnerability. The following PoC is available:  
  
  
http://host/manager/index.php?id=4%27+ANY_SQL&a=16  
  
You must also set the "Referer" HTTP header  
  
  
Vulnerability ID: HTB22412  
Reference: http://www.htbridge.ch/advisory/sql_injection_vulnerability_in_modx_cms_and_application_framework.html  
Product: MODx CMS and Application Framework  
Vendor: MODx   
Vulnerable Version: 1.0.3 and Probably Prior Versions  
Vendor Notification: 28 May 2010   
Vulnerability Type: SQL Injection  
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response  
Risk level: Medium   
Credit: High-Tech Bridge SA (http://www.htbridge.ch/)   
  
Vulnerability Details:  
The vulnerability exists due to failure in the "manager/index.php" script to properly sanitize user-supplied input in "a" variable. Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.  
  
Attacker can use browser to exploit this vulnerability. The following PoC is available:  
  
  
http://host/manager/index.php?a=106%27+ANY_SQL_HERE  
  
You must also set the "Referer" HTTP header  
  
  
`