Zikula 1.2.2 Cross Site Scripting

2010-04-28T00:00:00
ID PACKETSTORM:88987
Type packetstorm
Reporter High-Tech Bridge SA
Modified 2010-04-28T00:00:00

Description

                                        
                                            `Vulnerability ID: HTB22348  
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_zikula_application_framework.html  
Product: Zikula Application Framework  
Vendor: Zikula Software Foundation  
Vulnerable Version: 1.2.2 and Probably Prior Versions  
Vendor Notification: 13 April 2010   
Vulnerability Type: XSS (Сross Site Sсriрting)  
Status: Fixed by Vendor  
Risk level: Medium   
Credit: High-Tech Bridge SA (http://www.htbridge.ch/)   
  
Vulnerability Details:  
User can execute arbitrary JavaScript code within the vulnerable application.   
  
The vulnerability exists due to failure in the "ZLanguage.php" script to properly sanitize user-supplied input in "lang" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.  
  
An attacker can use browser to exploit this vulnerability. The following PoC is available:   
  
  
http://www.tst.my/?lang=en%27%22%3E%3Cimg%20src=0%20onerror=alert%28document.cookie%29%3E  
  
http://www.tst.my/index.php?module=adminpanel&type=admin&func=adminpanel&lang=en%27%22%3E%3Cimg%20src=0%20onerror=alert%28document.cookie%29%3E  
  
  
Solution: Upgrade to the most recent verison  
`