LearnDash WordPress LMS 3.1.2 Cross Site Scripting

2020-02-10T00:00:00
ID PACKETSTORM:156275
Type packetstorm
Reporter Jinson Varghese Behanan
Modified 2020-02-10T00:00:00

Description

                                        
                                            `# Exploit Title: LearnDash WordPress LMS Plugin 3.1.2 - Reflective Cross-Site Scripting  
# Date: 2020-01-14  
# Vendor Homepage: https://www.learndash.com  
# Vendor Changelog: https://learndash.releasenotes.io/release/uCskc-version-312  
# Exploit Author: Jinson Varghese Behanan  
# Author Advisory: https://www.getastra.com/blog/911/plugin-exploit/reflected-xss-vulnerability-found-in-learndash-lms-plugin/  
# Author Homepage: https://www.jinsonvarghese.com  
# Version: 3.0.0 - 3.1.1  
# CVE : CVE-2020-7108  
  
1. Description  
  
LearnDash is one of the most popular and easiest to use WordPress LMS plugins in the market. It allows users to easily create courses and sell them online and boasts a large customer base. The plugin allows users to search for courses they have subscribed to using the [ld_profile] search field, which was found to be vulnerable to reflected cross site scripting. All WordPress websites using LearnDash version 3.0.0 through 3.1.1 are affected.  
  
2. Proof of Concept  
  
Once the user is logged in to the WordPress website where the vulnerable LearnDash plugin is installed, the XSS payload can be inserted into the Search Your Courses box. The payload gets executed because the user input is not properly validated. As a result, passing the XSS payload as a query string in the URL will also execute the payload.  
  
[wordpress website][learndash my-account page]?ld-profile-search=%3Cscript%3Ealert(document.cookie)%3C/script%3E  
  
An attacker can modify the above URL and use an advanced payload that could help him/her in performing malicious actions.  
  
3. Timeline  
  
Vulnerability reported to the LearnDash team – January 14, 2020  
LearnDash version 3.1.2 containing the fix released – January 14, 2020  
`