SAP J2EE Engine/7.01/Fiori test2 Cross Site Scripting

2019-03-04T00:00:00
ID PACKETSTORM:151946
Type packetstorm
Reporter Ece Orsel
Modified 2019-03-04T00:00:00

Description

                                        
                                            `I. VULNERABILITY  
-------------------------  
SAP J2EE Engine/7.01/Fiori  
Reflected Cross Site Scripting (XSS)  
  
II. CVE REFERENCE  
-------------------------  
CVE-2018-17862  
  
III. VENDOR  
-------------------------  
https://www.sap.com  
  
IV. TIMELINE  
-------------------------  
10/08/2018 Vulnerability discovered  
12/07/2018 Vendor contacted  
19/07/2018 SAP reply that SAP J2EE engine/7.01 end of support  
  
V. CREDIT  
-------------------------  
Ece Orsel from Biznet Bilisim A.S.  
  
VI. DESCRIPTION  
-------------------------  
Cross Site Scripting (XSS) allows clients to inject scripts into a request and  
have the server return the script to the client in the response. This occurs  
because the application is taking untrusted data and reusing it  
without performing any validation or sanitisation.  
A remote user can conduct cross-site scripting attacks.  
  
Affected Component:  
  
Path(inurl): /TestJDBC_Web/test2  
Parameter: sys_jdbc  
  
VII. SOLUTION  
-------------------------  
Update SAP to lastest version.  
  
--   
B.Ece Arsel  
`