WordPress WordApp Mobile 2.0.3 Cross Site Scripting

2017-12-14T00:00:00
ID PACKETSTORM:145409
Type packetstorm
Reporter Ricardo Sanchez
Modified 2017-12-14T00:00:00

Description

                                        
                                            `Title: *WordPress WordApp Mobile App Plugin a Convert your WordPress Site to a Mobile App 2.0.3 Cross Site Scripting*  
  
File:  
Class Input Validation Error  
Remote Yes  
  
Credit Ricardo Sanchez  
Vulnerable WordApp Mobile App Plugin a Convert your WordPress Site to a Mobile App 2.0.3  
  
WordApp Mobile App Plugin a Convert your WordPress Site to a Mobile App is prone to a stored cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied data.  
  
An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.  
  
To exploit this issue following steps:  
  
The XSS reflected because the value appThemeSelected is not filter correctly:  
  
  
Demo Request:  
http://localhost//wordpress/wp-content/plugins/wordapp-mobile-app/themes/wordappjqmobileMyiOS/install.php?appThemeSelected=1</script>"><script>alert("R1XS4.COM")</script>  
  
  
  
`