WordPress Bulletproof 0.53.2 Cross Site Scripting

2016-03-15T00:00:00
ID PACKETSTORM:136235
Type packetstorm
Reporter Sachin Wagh
Modified 2016-03-15T00:00:00

Description

                                        
                                            `*Product: Bulletproof SecurityExploit Author: Sachin WaghAffected Version:  
0.53.2*  
  
*Fixed Version:** 0.53.3 *  
(http://forum.ait-pro.com/forums/topic/bps-changelog/  
<http://forum.ait-pro.com/forums/topic/bps-changelog/>)  
  
  
*Home page Link: https://wordpress.org/plugins/bulletproof-security/  
<https://wordpress.org/plugins/bulletproof-security/>*  
  
  
*Detail:*  
  
  
The Bulletproof Security plugin for WordPress is prone to a multiple  
cross-site scripting vulnerabilities because it fails to sufficiently  
sanitize user-supplied input.  
  
  
An attacker may leverage this issues to execute arbitrary script code in  
the browser of an unsuspecting user in the context of the affected site.  
This may allow the attacker to steal cookie-based authentication  
credentials and to launch other attacks.  
  
  
*Vulnerable Product:* [+] Bulletproof Security 0.53.2  
  
*Vulnerable Parameter(s) : *  
  
[+] bulletproof_security_options_email[bps_send_email_cc]  
  
[+] bulletproof_security_options_email[bps_send_email_bcc]  
  
  
  
*Affected Area(s): *  
  
  
[+]  
http://localhost/wordpress-4.4/wordpress/wpadmin/admin.php?page=bulletproof-security%2Fadmin%2Flogin%2Flogin.php  
  
  
*Credit:*  
  
  
Sachin Wagh (@tiger_tigerboy)  
`