ClipperCMS 1.3.0 Cross Site Request Forgery

2015-11-16T00:00:00
ID PACKETSTORM:134356
Type packetstorm
Reporter Tim Coen
Modified 2015-11-16T00:00:00

Description

                                        
                                            `Security Advisory - Curesec Research Team  
  
1. Introduction  
  
Affected Product: ClipperCMS 1.3.0  
Fixed in: not fixed  
Fixed Version Link: n/a  
Vendor Website: http://www.clippercms.com/  
Vulnerability Type: CSRF  
Remote Exploitable: Yes  
Reported to vendor: 10/02/2015  
Disclosed to public: 11/13/2015  
Release mode: Full Disclosure  
CVE: n/a  
Credits Tim Coen of Curesec GmbH  
  
2. Vulnerability Description  
  
CVSS  
  
Medium 5.1 AV:N/AC:L/Au:S/C:P/I:P/A:P  
  
Description  
  
The only protection against CSRF is a referer check. This check can be disabled  
by a user with the rights to edit settings, thus making the application  
vulnerable to CSRF.  
  
A user may choose to disable referer checks, because when they are enabled,  
external links or direct entry/bookmarks to specific pages in the backend do  
not work, which severely limits the usability of the application  
  
3. Solution  
  
This issue has not been fixed by the vendor.  
  
4. Report Timeline  
  
10/02/2015 Informed Vendor about Issue (no reply)  
10/21/2015 Reminded Vendor of Disclosure Date (no reply)  
11/13/2015 Disclosed to public  
  
  
Blog Reference:  
http://blog.curesec.com/article/blog/ClipperCMS-130-CSRF-97.html  
  
  
`