Barracuda Web Filter 910 5.0.015 Cross Site Scripting

2012-09-05T00:00:00
ID PACKETSTORM:116239
Type packetstorm
Reporter Benjamin Kunz Mejri
Modified 2012-09-05T00:00:00

Description

                                        
                                            `Title:  
======  
Barracuda Web Filter 910 5.0.015 - Multiple Vulnerabilities  
  
  
Date:  
=====  
2012-08-02  
  
  
References:  
===========  
http://www.vulnerability-lab.com/get_content.php?id=570  
  
Barracuda Networks Security ID: BNSEC-279/BNYF-5533  
  
  
VL-ID:  
=====  
570  
  
  
Common Vulnerability Scoring System:  
====================================  
4.5  
  
  
Introduction:  
=============  
The Barracuda Web Filter is an integrated content filtering, application blocking and malware protection   
solution that is powerful, easy to use and affordable for businesses of all sizes. It enforces Internet   
usage policies by blocking access to Web sites and Internet applications that are not related to business,   
and it easily and completely eliminates spyware and other forms of malware from your organization. No more   
productivity loss trying to repair computers or make computers usable again.  
  
Blocks access to Web sites based on domain, URL pattern, or content category  
Blocks downloads based on file type  
Blocks applications that access the Internet, including IM, music services, and software update utilities  
Integrates with safe search filters built into popular images search engines  
Provides integrated gateway and desktop spyware protection  
Uses Barracuda Web Security Agents compatible with Windows PC’s and Macs to enforce Internet policies on off-network computers  
  
The Barracuda Web Filter combines preventative, reactive, and proactive measures to form a complete Web   
filtering solution. Designed for the enterprise, the Barracuda Web Filter enables you to set up custom policies   
for particular users and groups across customizable time ranges. The Barracuda Web Filter integrates with popular   
LDAP directory servers, such as Microsoft Active Directory, for both authentication and group membership   
information on which to apply custom policies. Sample uses of group policies include:  
  
Restricting access to job board Web sites to only the Human Resources group  
Defining separate policies for teachers and students at a school  
Enabling compliance officers unrestricted access to the Web for investigation  
Providing external instant messaging (e.g., AIM) access only to specific users or groups  
Restricting personal Web browsing to non-working hours  
  
For organizations that do not utilize directory servers, policies can be defined for unauthenticated users as a whole,   
locally defined users and groups, or network IP address ranges.  
  
(Copy of the Vendor Homepage: http://www.barracudanetworks.com/ns/products/web-filter-overview.php )  
  
  
Abstract:  
=========  
The Vulnerability Lab Research Team discovered multiple Web Vulnerabilities in Barracudas Web Filter Application v5.0.0.015 Appliance Model 910.  
  
  
Report-Timeline:  
================  
2012-05-01: Researcher Notification & Coordination  
2012-05-08: Vendor Notification  
2012-06-13: Vendor Response/Feedback  
2012-07-25: Vendor Fix/Patch  
2012-08-02: Public or Non-Public Disclosure  
  
  
Status:  
========  
Published  
  
  
Affected Products:  
==================  
Barracuda Networks  
Product: Barracuda Web Filter Appliance 910 v5.0.0.015  
  
  
Exploitation-Technique:  
=======================  
Remote  
  
  
Severity:  
=========  
Medium  
  
  
Details:  
========  
Multiple persistent input validation vulnerabilities are detected in the Barracudas Web Filter Application v5.0.0.015 Appliance Model 910.   
The bugs allow remote attackers to implement/inject malicious script code on the application side (persistent). Successful exploitation   
of the vulnerability can lead to session hijacking (manager/admin) or stable (persistent) context manipulation. Exploitation requires   
low user inter action. The vulnerability is located in the NTLM Edit - Host & Domain Name which is bound to the affected vulnerable   
Existing Authentication Services listing. Another vulnerability is located on the upload key tab in combination with the   
unsanitized short domain name input field + output listing.  
  
  
Vulnerable Module(s):  
[+] Authentification > New Authentication Service  
[-] NTLM - Server Hostname & Domain Name - Existing Authentication Services  
  
[+] Authentification > Kerberos > Advanced Settings  
[-] Upload Key Tab File in combination with alternative Short Domain Name  
  
Picture(s):  
../1.png  
../2.png  
  
  
Proof of Concept:  
=================  
The persistent web vulnerabilities can be exploited by remote attackers with high[-](medium+) user inter action or via   
local low privileged user account with low require user inter action. For demonstration or reproduce ...  
  
Review: NTLM Edit & Listing  
  
<td colspan="2" style="" valign="top" width="285"><input autocomplete="off" id="UPDATE_ntlm_server_hostname:  
md5UBwQ8iCjrc1egk1wTV8SEg" name="UPDATE_ntlm_server_hostname:md5UBwQ8iCjrc1egk1wTV8SEg" size="30" value=""  
><[PERSISTENT SCRIPT CODE EXECUTION!] <" type="text"><br><div nowrap="" id="host2" style="height: 20px;"> </div></td>  
  
... &  
  
<td colspan="2" style="" valign="top" width="285"><input autocomplete="off" id="UPDATE_ntlm_server_hostname:  
md5UBwQ8iCjrc1egk1wTV8SEg" name="UPDATE_ntlm_server_hostname:md5UBwQ8iCjrc1egk1wTV8SEg" size="30" value=""  
><[PERSISTENT SCRIPT CODE EXECUTION!]") <" type="text"><br><div nowrap="" id="host2" style="height: 20px;"> </div></td>  
  
Affected:  
[+] Existing Authentication Services via NTLM Edit  
  
  
Review: Kerberos > Advanced Settings > Upload Key Tab File in combination with alternative Short Domain Name (Input)  
  
<td style="" valign="top" width="150">Upload keytab:</td>  
<td style="" valign="top" width="260">  
<div style="position: relative; height: 25px; padding-top: 0px;">  
<input disabled="disabled" id="upload_keytab" name="upload_keytab" onchange=" $('tmp_upload_keytab').value=this.value;"   
size="17" style="z-index: 2; opacity: 0; position: absolute; cursor: pointer; text-align: left;" type="file">  
<div style="position: absolute; z-index: 1; height: 25px;"><input size="20" id="tmp_upload_keytab">  
<input class="new_button disabled_button" disabled="disabled" id="Datei auswählen..." name="Datei auswählen..."   
style="cursor: pointer;" value="Datei auswählen..." type="button"></div></div></td>  
<td style="" valign="top" width="50"><br><div nowrap="" id="kerberos_keytab" style=""> </div></td>  
<td style="" valign="top" width="400"><div id="helpbox"><b class="outlinetop">  
<b class="outline1"></b>  
<b class="outline2"></b>  
<b class="outline3"></b>  
<b class="outline4"></b></b>  
<div id="contents"><div>This keytab file is generated by running the <b>ktpass.exe</b> program from your Windows command line.</div></div>  
<b class="outlinebottom"><b class="outline4"></b><b class="outline3"></b><b class="outline2"></b><b class="outline1"></b></b>  
</div></td>  
<td style="" valign="top" width="10"> </td>  
</tr>  
<tr class="config_module_tr" id="config_module_row_kerberos__8">  
<td valign="top" width="15"> </td>  
<td style="" valign="top" width="150">Short Domain Name:</td>  
  
... &  
  
<td valign="top" width="15"> </td>  
<td style="" valign="top" width="150">Short Domain Name:</td>  
<td style="" valign="top" width="260"><input autocomplete="off"   
id="UPDATE_new_kerberos_server_short_domain_name"   
name="UPDATE_new_kerberos_server_short_domain_name"   
size="30" type="text"></td>  
  
  
Affected:  
[+] Kerberos - Existing Authentication Services via Kerberos Advanced Edit - Upload & Short Domain Name  
  
  
Solution:  
=========  
Barracuda Networks solved this issue in the Barracuda Networks Webfilter firmware 6.0.0 and up.   
This release is generally available (to all our customers) July 25th, 2012.  
  
The persistent vulnerabilities can be patched by a char restriction of the vulnerable input fields & by parsing the input/output.  
Secure the input preview listing of edit ntlm and the output listing in Existing Authentication Services to secure the complete function.  
  
  
Risk:  
=====  
The security risk of the both persistent input validation vulnerabilities at the same location are estimated as medium(+).  
  
  
Credits:  
========  
Vulnerability Laboratory [Research Team] - Benjamin Kunz Mejri (bkm@vulnerability-lab.com)  
  
  
Disclaimer:  
===========  
The information provided in this advisory is provided as it is without any warranty. Vulnerability-Lab disclaims all warranties,   
either expressed or implied, including the warranties of merchantability and capability for a particular purpose. Vulnerability-  
Lab or its suppliers are not liable in any case of damage, including direct, indirect, incidental, consequential loss of business   
profits or special damages, even if Vulnerability-Lab or its suppliers have been advised of the possibility of such damages. Some   
states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation   
may not apply. We do not approve or encourage anybody to break any vendor licenses, policies, deface websites, hack into databases   
or trade with fraud/stolen material.  
  
Domains: www.vulnerability-lab.com - www.vuln-lab.com - www.vulnerability-lab.com/register  
Contact: admin@vulnerability-lab.com - support@vulnerability-lab.com - research@vulnerability-lab.com  
Section: video.vulnerability-lab.com - forum.vulnerability-lab.com - news.vulnerability-lab.com  
Social: twitter.com/#!/vuln_lab - facebook.com/VulnerabilityLab - youtube.com/user/vulnerability0lab  
Feeds: vulnerability-lab.com/rss/rss.php - vulnerability-lab.com/rss/rss_upcoming.php - vulnerability-lab.com/rss/rss_news.php  
  
Any modified copy or reproduction, including partially usages, of this file requires authorization from Vulnerability Laboratory.   
Permission to electronically redistribute this alert in its unmodified form is granted. All other rights, including the use of other   
media, are reserved by Vulnerability-Lab Research Team or its suppliers. All pictures, texts, advisories, sourcecode, videos and   
other information on this website is trademark of vulnerability-lab team & the specific authors or managers. To record, list (feed),   
modify, use or edit our material contact (admin@vulnerability-lab.com or support@vulnerability-lab.com) to get a permission.  
  
Copyright © 2012 | Vulnerability Laboratory  
  
  
  
--   
VULNERABILITY RESEARCH LABORATORY  
LABORATORY RESEARCH TEAM  
CONTACT: research@vulnerability-lab.com  
  
`