I want to warn you about multiple security vulnerabilities in plugin
Organizer for WordPress. This is the second in series of advisories
concerning vulnerabilities in this plugin.
These are Cross-Site Scripting (reflected and persistent), Cross-Site
Request Forgery and Arbitrary File Upload (Code Execution) vulnerabilities.
Vulnerable are Organizer 1.2.1 and previous versions.
As answered me the developer of the plugin, he doesn't support it anymore
and will not be fixing any vulnerabilities in it.
XSS (Persistent) (WASC-08):
Code will execute at the page users.php of the plugin.
Via attack on function Add/Edit User Setting (which combined into the same
POST request) it's possible to add and edit settings.
POST request at page
http://site/wp-admin/admin.php?page=organizer/page/users.php. Similarly to
above exploit for XSS.
Via attack on function Delete User Setting it's possible to delete settings.
Arbitrary File Upload (Code Execution) (WASC-31):
It's possible to upload arbitrary files with code execution (php files).
Because in field "File extensions allowed" it's possible to set extensions
of scripts, such as "php".
This will allow to upload to the server and execute arbitrary scripts.
Besides attacking admin via above-mentioned CSRF vulnerability for changing
of the settings (or getting access to admin account for this), the
Insufficient Authorization vulnerability (described in the third advisory)
also can be used for this (in the presence of account even with lowest
rights as Subscriber).
2012.04.15 - informed the developer about previous vulnerabilities.
2012.04.16 - announced at my site (http://websecurity.com.ua/5786/).
2012.04.17 - the developer answered, that he didn't support the plugin
2012.04.17 - additionally informed the developer about new vulnerabilities.
2012.04.24 - disclosed at my site.
Best wishes & regards,
Administrator of Websecurity web site