I want to warn you about Cross-Site Scripting, Full path disclosure, Abuse
of Functionality and Denial of Service vulnerabilities in The Gazette
Edition theme for WordPress. It's commercial theme for WP by WooThemes.
Vulnerable are The Gazette Edition 2.9.4 and previous versions. XSS is
possible only in old versions of the theme. Recently in version The Gazette
Edition 2.9.5 most of these vulnerabilities were fixed (but there were still
left many not fixed FPD).
Full path disclosure (WASC-13):
And also tens of php-scripts of the theme in folder /gazette/ and all
Abuse of Functionality (WASC-42):
About such AoF and DoS vulnerabilities I wrote in article Using of the sites
for attacks on other sites
Beside folder /gazette/ in folder with themes, this theme also can be placed
in folder /gazette-dev/gazette/.
2011.02.01 - informed developers about other themes.
2011.02.03 - announced at my site.
2011.02.04 - additionally informed developers about this theme.
2011.02.04-12 - conversation about fixing holes in all their themes for
WordPress. At first they tried to fix all these holes in themes at their own
2011.02.22 - developers released version 2.9.5.
2011.04.11 - disclosed at my site.
I mentioned about these vulnerabilities at my site
Best wishes & regards,
Administrator of Websecurity web site