SoX Compand Effect Overflow

2003-03-22T10:04:27
ID OSVDB:9022
Type osvdb
Reporter OSVDB
Modified 2003-03-22T10:04:27

Description

Vulnerability Description

SoX contains a flaw related to the 'compand effect' feature that may allow an attacker to cause an integer overflow. No further details have been provided.

Solution Description

Upgrade to version 12.17.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

SoX contains a flaw related to the 'compand effect' feature that may allow an attacker to cause an integer overflow. No further details have been provided.

References:

Vendor URL: http://sox.sourceforge.net/ Vendor Specific Advisory URL