Mambo Open Source articles.php artid Variable SQL Injection

2003-12-10T00:00:00
ID OSVDB:7483
Type osvdb
Reporter Lifo Fifo(lifofifo20@yahoo.com)
Modified 2003-12-10T00:00:00

Description

Vulnerability Description

Mambo Server contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the "artid" variable in the "articles.php" script is not verified properly and will allow an attacker to inject or manipulate SQL queries.

Solution Description

Upgrade to version 4.0.14 patch 02 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

Mambo Server contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the "artid" variable in the "articles.php" script is not verified properly and will allow an attacker to inject or manipulate SQL queries.

References:

Vendor URL: http://www.mamboserver.com/ Secunia Advisory ID:10413 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2003-12/0164.html ISS X-Force ID: 13959 Bugtraq ID: 9196