Midnight Commander Unspecified Buffer Overflows

2004-04-29T07:37:20
ID OSVDB:5722
Type osvdb
Reporter Jakub Jelinek ()
Modified 2004-04-29T07:37:20

Description

Vulnerability Description

Midnight Commander contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is due to multiple non-descript overflows. No further details have been provided.

Solution Description

Midnight Commander is distributed with many versions of Linux who maintain their own version. As a result, the version number to upgrade to will vary for each distribution. Please consult your specific distribution for exact fix information.

Debian users upgrade to: 4.5.55-1.2woody3 Mandrake users upgrade to: 4.6.0

Short Description

Midnight Commander contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is due to multiple non-descript overflows. No further details have been provided.

References:

Vendor Specific Advisory URL Vendor Specific Advisory URL Vendor Specific Advisory URL Secunia Advisory ID:11502 Secunia Advisory ID:11720 Secunia Advisory ID:11668 Related OSVDB ID: 5721 Related OSVDB ID: 5720 CVE-2004-0226