phpRPG index.php Multiple Variable SQL Injection

2007-12-17T00:00:00
ID OSVDB:39261
Type osvdb
Reporter OSVDB
Modified 2007-12-17T00:00:00

Description

Vulnerability Description

phpRPG contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the index.php script not properly sanitizing user-supplied input to the username and password variables. This may allow an attacker to inject or manipulate SQL queries in the backend database.

Technical Description

This vulnerability is only present when the magic_quotes_gpc PHP option is 'off'.

References:

Vendor URL: http://sourceforge.net/projects/phprpg/ Secunia Advisory ID:27968 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2007-12/0198.html CVE-2007-6484 CVE-2007-6469