PHP glibc Implementation fnmatch() Function Overflow

2007-09-04T02:18:21
ID OSVDB:38686
Type osvdb
Reporter OSVDB
Modified 2007-09-04T02:18:21

Description

Solution Description

Upgrade to version 5.2.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

References:

Vendor URL: http://www.php.net/ Vendor Specific Solution URL: http://www.gentoo.org/security/en/glsa/glsa-200710-02.xml Vendor Specific News/Changelog Entry: http://www.php.net/releases/5_2_5.php Secunia Advisory ID:27102 Secunia Advisory ID:27659 Secunia Advisory ID:27648 Related OSVDB ID: 38682 Related OSVDB ID: 38683 Related OSVDB ID: 38687 Related OSVDB ID: 38688 Related OSVDB ID: 38684 Related OSVDB ID: 38685 Related OSVDB ID: 38680 Related OSVDB ID: 38681 Other Advisory URL: http://lists.rpath.com/pipermail/security-announce/2007-November/000277.html Other Advisory URL: http://securityreason.com/securityalert/3109 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2007-09/0049.html ISS X-Force ID: 36461 ISS X-Force ID: 36457 CVE-2007-4782