activeWeb contentserver mimetype msg Variable XSS

2007-07-13T17:07:40
ID OSVDB:36261
Type osvdb
Reporter RedTeam Pentesting()
Modified 2007-07-13T17:07:40

Description

Vulnerability Description

contentserver contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'msg' variable upon submission to the mimetype script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Solution Description

Upgrade to version 5.6.2964 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

contentserver contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'msg' variable upon submission to the mimetype script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Manual Testing Notes

<script>alert('XSS')</script>

References:

Secunia Advisory ID:26063 Related OSVDB ID: 36260 Related OSVDB ID: 36259 Other Advisory URL: http://www.redteam-pentesting.de/advisories/rt-sa-2007-005.php Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2007-07/0133.html ISS X-Force ID: 35389 CVE-2007-3014 Bugtraq ID: 24895 Bugtraq ID: 24896