Crea-book admin/uninstall_table.php Multiple Variable SQL Injection

2007-04-11T09:19:12
ID OSVDB:34829
Type osvdb
Reporter Anonymous (via Secunia)()
Modified 2007-04-11T09:19:12

Description

Vulnerability Description

Crea-book contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the admin/uninstall_table.php script not properly sanitizing user-supplied input to the 'pseudo' or 'passe' variables. This may allow an attacker to inject or manipulate SQL queries in the backend database.

Technical Description

This vulnerability is only present when the magic_quotes_gpc PHP option is 'off'.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

Crea-book contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the admin/uninstall_table.php script not properly sanitizing user-supplied input to the 'pseudo' or 'passe' variables. This may allow an attacker to inject or manipulate SQL queries in the backend database.

References:

Vendor URL: http://www.comscripts.com/scripts/php.creabook.1359.html Secunia Advisory ID:24862 Related OSVDB ID: 34823 Related OSVDB ID: 34827 Related OSVDB ID: 34819 Related OSVDB ID: 34826 Related OSVDB ID: 34817 Related OSVDB ID: 34818 Related OSVDB ID: 34820 Related OSVDB ID: 34821 Related OSVDB ID: 34828 Related OSVDB ID: 34816 Related OSVDB ID: 34822 Related OSVDB ID: 34824 Related OSVDB ID: 34825 CVE-2007-2314