WordPress contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the URL variable names upon submission. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.
Upgrade to version 2.0.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.
WordPress 2.0.5 CSRF Protection Scheme XSS
Vendor Specific News/Changelog Entry: http://wordpress.org/development/2007/01/wordpress-206/ Secunia Advisory ID:23595 Other Advisory URL: http://www.hardened-php.net/advisory_012007.140.html Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2007-01/0155.html FrSIRT Advisory: ADV-2007-0061 CVE-2007-0106 Bugtraq ID: 21893