miniBB bb_func_usernfo.php Website Name Field XSS

2003-12-30T14:35:02
ID OSVDB:3304
Type osvdb
Reporter OSVDB
Modified 2003-12-30T14:35:02

Description

Vulnerability Description

miniBB contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the URL of a user's profile in the bb_edit_prf.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Solution Description

Upgrade to version 1.7b or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

miniBB contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the URL of a user's profile in the bb_edit_prf.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Manual Testing Notes

Create a user in the forums with your website name as: http://blah.com"></a><script>alert(document.cookie)</script>

Using your userid (5 in this example), clicking the following will execute the script: http://[target]/index.php?action=userinfo&user=5

References:

Vendor Specific Advisory URL Secunia Advisory ID:10517 Other Advisory URL: http://archives.neohapsis.com/archives/fulldisclosure/2003-q4/3822.html Nessus Plugin ID:11972 ISS X-Force ID: 14095 Bugtraq ID: 9310