a-blog Unspecified XSS

2006-12-22T08:18:52
ID OSVDB:32402
Type osvdb
Reporter Fukumori()
Modified 2006-12-22T08:18:52

Description

Vulnerability Description

a-blog contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate unspecified variables upon submission to an unspecified script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Solution Description

Upgrade to version 1.52 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

a-blog contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate unspecified variables upon submission to an unspecified script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

References:

Vendor Specific News/Changelog Entry: http://www.a-blog.jp/news/index.php Secunia Advisory ID:23444 Other Advisory URL: http://jvn.jp/jp/JVN%2378520316/index.html ISS X-Force ID: 31038 FrSIRT Advisory: ADV-2006-5129 CVE-2006-6729 Bugtraq ID: 21716