Discloser plugins/plugins.php type Variable Remote File Inclusion

2006-08-16T02:11:28
ID OSVDB:29352
Type osvdb
Reporter OSVDB
Modified 2006-08-16T02:11:28

Description

Vulnerability Description

Discloser has been reported to contain a flaw that may allow a remote attacker to execute arbitrary commands. The issue is supposedly due to the plugins/plugins.php script not properly sanitizing user input supplied to the 'type' variable. However, subsequent examination indicates the variable is set before an attacker can manipulate it.

Solution Description

The vulnerability reported is incorrect. No solution required.

Short Description

Discloser has been reported to contain a flaw that may allow a remote attacker to execute arbitrary commands. The issue is supposedly due to the plugins/plugins.php script not properly sanitizing user input supplied to the 'type' variable. However, subsequent examination indicates the variable is set before an attacker can manipulate it.

References:

Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-08/0390.html Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-08/0337.html Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-08/0348.html Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-08/0440.html CVE-2006-4557