CakePHP vendors.php file Variable Traversal Arbitrary File Access

2006-09-21T13:49:03
ID OSVDB:29055
Type osvdb
Reporter OSVDB
Modified 2006-09-21T13:49:03

Description

Solution Description

Upgrade to version 1.1.8.3544 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Manual Testing Notes

http://[target]/js/vendors.php?file=../../../../.htpasswd%00foobar.js

References:

Vendor URL: http://cakeforge.org/ Secunia Advisory ID:22040 Other Advisory URL: http://www.gulftech.org/?node=research&article_id=00114-09212006& CVE-2006-5031 Bugtraq ID: 20150