mambo-phpShop mod_phpshop_cart.php mosConfig_absolute_path Variable Remote File Inclusion

2006-08-18T00:51:56
ID OSVDB:28153
Type osvdb
Reporter O.U.T.L.A.W(outlaw@aria-security.net)
Modified 2006-08-18T00:51:56

Description

Vulnerability Description

mambo-phpShop contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to mod_phpshop_cart.php not properly sanitizing user input supplied to the 'mosConfig_absolute_path' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

Technical Description

This vulnerability is only present when the register_globals PHP option is set to 'on'. This has not been the default setting for PHP installs since version 4.2.0 (22-Apr-2002).

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

mambo-phpShop contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to mod_phpshop_cart.php not properly sanitizing user input supplied to the 'mosConfig_absolute_path' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

References:

Related OSVDB ID: 28151 Related OSVDB ID: 28155 Related OSVDB ID: 28158 Related OSVDB ID: 28156 Related OSVDB ID: 28152 Related OSVDB ID: 28154 Related OSVDB ID: 28157 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-08/0363.html Mail List Post: http://attrition.org/pipermail/vim/2006-August/000989.html Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-08/0436.html Keyword: ISS X-Force ID: 28441 CVE-2006-4263 Bugtraq ID: 19591