Dokeos Multiple Unspecified XSS

2006-07-28T09:49:10
ID OSVDB:27586
Type osvdb
Reporter OSVDB
Modified 2006-07-28T09:49:10

Description

Vulnerability Description

Dokeos contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate unspecified variable(s) upon submission to unspecified script(s). This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Solution Description

Upgrade to version 1.6.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

Dokeos contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate unspecified variable(s) upon submission to unspecified script(s). This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

References:

Vendor Specific News/Changelog Entry: http://www.dokeos.com/news.php#145 Secunia Advisory ID:21239 Keyword: Wapiti CVE-2006-3924 Bugtraq ID: 19210