NewsPHP index.php Multiple Variable SQL Injection

2006-06-29T11:34:00
ID OSVDB:26977
Type osvdb
Reporter Ellipsis Security(securityconnection@gmail.com)
Modified 2006-06-29T11:34:00

Description

Vulnerability Description

NewsPHP contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the index.php script not properly sanitizing user-supplied input to the 'words', 'id', 'topmenuitem', 'cat_id', and 'words' variables. This may allow an attacker to inject or manipulate SQL queries in the backend database.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

NewsPHP contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the index.php script not properly sanitizing user-supplied input to the 'words', 'id', 'topmenuitem', 'cat_id', and 'words' variables. This may allow an attacker to inject or manipulate SQL queries in the backend database.

Manual Testing Notes

http://[target]/?words='[SQL] http://[target]/?words=%27[SQL]&where=1 http://[target]/index.php?id='[SQL] http://[target]/index.php?topmenuitem='[SQL] http://[target]/index.php?cat_id='[SQL] http://[target]/index.php?words='[SQL]&where=1

References:

Vendor URL: http://www.newsphp.com/ Secunia Advisory ID:20943 Related OSVDB ID: 26978 Related OSVDB ID: 26976 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-07/0001.html ISS X-Force ID: 27508 FrSIRT Advisory: ADV-2006-2640 CVE-2006-3358 CVE-2006-3359 Bugtraq ID: 18726