phpTRADER buynow.php Multiple Variable SQL Injection

2006-06-21T05:18:57
ID OSVDB:26699
Type osvdb
Reporter r0t(krustevs@googlemail.com)
Modified 2006-06-21T05:18:57

Description

Vulnerability Description

phpTRADER contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the buynow.php script not properly sanitizing user-supplied input to the 'sectio' and 'adnr' variables. This may allow an attacker to inject or manipulate SQL queries in the backend database.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

phpTRADER contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the buynow.php script not properly sanitizing user-supplied input to the 'sectio' and 'adnr' variables. This may allow an attacker to inject or manipulate SQL queries in the backend database.

References:

Vendor URL: http://www.bluehouse-project.de/index.php?area=1&p=product Security Tracker: 1016356 Secunia Advisory ID:20740 Related OSVDB ID: 26697 Related OSVDB ID: 26705 Related OSVDB ID: 26706 Related OSVDB ID: 26701 Related OSVDB ID: 26702 Related OSVDB ID: 26704 Related OSVDB ID: 26698 Related OSVDB ID: 26703 Related OSVDB ID: 26696 Related OSVDB ID: 26700 Other Advisory URL: http://pridels.blogspot.com/2006/06/phptrader-multiple-sql-injection-vuln.html FrSIRT Advisory: ADV-2006-2469 CVE-2006-3152